# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*? - |\\n.*|[^\w\s]+//gm;t' <<< "V0.00 - Books are on the table\nPick them up
Books are on the table\nPick them up
Pens are in the bag\nBring them
Cats are roaming around
Dogs are sitting
Pencils, erasers, ruler cannot be found\nSearch them
Laptops, headphones are lost\nSearch for them"