# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*? - |\\n.*|[^\w\s]+"
test_str = ("V0.00 - Books are on the table\\nPick them up\n"
"Books are on the table\\nPick them up\n"
"Pens are in the bag\\nBring them\n"
"Cats are roaming around\n"
"Dogs are sitting\n"
"Pencils, erasers, ruler cannot be found\\nSearch them\n"
"Laptops, headphones are lost\\nSearch for them")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.