use strict;
my $str = 'V0.00 - Books are on the table\\nPick them up
Books are on the table\\nPick them up
Pens are in the bag\\nBring them
Cats are roaming around
Dogs are sitting
Pencils, erasers, ruler cannot be found\\nSearch them
Laptops, headphones are lost\\nSearch for them';
my $regex = qr/^.*? - |\\n.*|[^\w\s]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";