const regex = /(?:\{\%\hfor\h(?:[^\s^%^|]+)\hin\h([^\s^%^|]+)\h\%\})([\s\S]*?(?=\n.*?\{\{\h([^\s^\.]+)\.([^\s]+)\h\}\}))([\s\S]*?(?!\n.*?\{\%\hendfor\h\%\}))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\{\\%\\hfor\\h(?:[^\\s^%^|]+)\\hin\\h([^\\s^%^|]+)\\h\\%\\})([\\s\\S]*?(?=\\n.*?\\{\\{\\h([^\\s^\\.]+)\\.([^\\s]+)\\h\\}\\}))([\\s\\S]*?(?!\\n.*?\\{\\%\\hendfor\\h\\%\\}))', 'g')
const str = `{% for user in users %}
Hello, {{ user.name }}, you are {{ user.age }} {{ user.name }}
ssssssssssssssssssssss {{ user.name }}
sdsddddddddddddddddddddddddddddd
{% endfor %}
{% for dog in dogs %}
Your dog is {{ dog.age }} and likes {{ dog.food }}.
{% endfor %}
wwww
{{ user.name }}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}