$re = '/(?:\{\%\hfor\h(?:[^\s^%^|]+)\hin\h([^\s^%^|]+)\h\%\})([\s\S]*?(?=\n.*?\{\{\h([^\s^\.]+)\.([^\s]+)\h\}\}))([\s\S]*?(?!\n.*?\{\%\hendfor\h\%\}))/';
$str = '{% for user in users %}
Hello, {{ user.name }}, you are {{ user.age }} {{ user.name }}
ssssssssssssssssssssss {{ user.name }}
sdsddddddddddddddddddddddddddddd
{% endfor %}
{% for dog in dogs %}
Your dog is {{ dog.age }} and likes {{ dog.food }}.
{% endfor %}
wwww
{{ user.name }}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);