use strict;
my $str = '{% for user in users %}
Hello, {{ user.name }}, you are {{ user.age }} {{ user.name }}
ssssssssssssssssssssss {{ user.name }}
sdsddddddddddddddddddddddddddddd
{% endfor %}
{% for dog in dogs %}
Your dog is {{ dog.age }} and likes {{ dog.food }}.
{% endfor %}
wwww
{{ user.name }}';
my $regex = qr/(?:\{\%\hfor\h(?:[^\s^%^|]+)\hin\h([^\s^%^|]+)\h\%\})([\s\S]*?(?=\n.*?\{\{\h([^\s^\.]+)\.([^\s]+)\h\}\}))([\s\S]*?(?!\n.*?\{\%\hendfor\h\%\}))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}