import Foundation
let pattern = #"(?:\{\%\hfor\h(?:[^\s^%^|]+)\hin\h([^\s^%^|]+)\h\%\})([\s\S]*?(?=\n.*?\{\{\h([^\s^\.]+)\.([^\s]+)\h\}\}))([\s\S]*?(?!\n.*?\{\%\hendfor\h\%\}))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{% for user in users %}
Hello, {{ user.name }}, you are {{ user.age }} {{ user.name }}
ssssssssssssssssssssss {{ user.name }}
sdsddddddddddddddddddddddddddddd
{% endfor %}
{% for dog in dogs %}
Your dog is {{ dog.age }} and likes {{ dog.food }}.
{% endfor %}
wwww
{{ user.name }}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)