#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z ',-]+\.?)$"
Local $sString = "Baxter" & @CRLF & _
"Doe de Sour Jr." & @CRLF & _
"Smith-Brown" & @CRLF & _
"Mathias d'Arras" & @CRLF & _
"d'Arras" & @CRLF & _
"King, Jr." & @CRLF & _
"Cotton III" & @CRLF & _
"Baxter2" & @CRLF & _
"user@gmail" & @CRLF & _
"#michael" & @CRLF & _
"tina.fay"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")