import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z ',-]+\\.?)$";
final String string = "Baxter\n"
+ "Doe de Sour Jr.\n"
+ "Smith-Brown\n"
+ "Mathias d'Arras\n"
+ "d'Arras\n"
+ "King, Jr.\n"
+ "Cotton III\n"
+ "Baxter2\n"
+ "user@gmail\n"
+ "#michael\n"
+ "tina.fay";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}