const regex = /^([A-Za-z ',-]+\.?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z \',-]+\\.?)$', 'gm')
const str = `Baxter
Doe de Sour Jr.
Smith-Brown
Mathias d'Arras
d'Arras
King, Jr.
Cotton III
Baxter2
user@gmail
#michael
tina.fay`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}