using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"lex=\""(.*)\"" gr=\""(.*)\""><\/ana>(.*)<\/w>";
string input = @"<w><ana lex=""совершенно"" gr=""ADV""></ana>соверш`енно</w>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}