$re = '/lex=\"(.*)\" gr=\"(.*)\"><\/ana>(.*)<\/w>/';
$str = '<w><ana lex="совершенно" gr="ADV"></ana>соверш`енно</w>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);