package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`lex=\"(.*)\" gr=\"(.*)\"><\/ana>(.*)<\/w>`)
var str = `<w><ana lex="совершенно" gr="ADV"></ana>соверш\`енно</w>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}