re = /lex=\"(.*)\" gr=\"(.*)\"><\/ana>(.*)<\/w>/
str = '<w><ana lex="совершенно" gr="ADV"></ana>соверш`енно</w>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end