using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<= \;)( \;| |\n|\r)+";
string input = @"<tr><td align=""left"" style=""color: #6e6f74; font-family: Arial, Helvetica, sans-serif; font-size: 14px; padding: 0px 0px 0px 10px; text-align: left;""><a href=""http://www.theherbsplace.com/onsale"" style=""color: #5583c7;"" target=""_blank""><img alt=""Nature's Sunshine"" src=""http://image.exct.net/lib/ff2c1c757166/i/4/096bf034-0.jpg"" style=""border: 0px; display: block;"" /></a></td><td align=""right"" style=""color: #6e6f74; font-family: Arial, Helvetica, sans-serif; font-size: 14px; padding: 0px;"" valign=""middle"">
<table border=""0"" cellpadding=""0"" cellspacing=""0"" style=""border-spacing: 0px;""><tbody>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}