import re
regex = re.compile(r"(?<= \;)( \;| |\n|\r)+")
test_str = ("<tr><td align=\"left\" style=\"color: #6e6f74; font-family: Arial, Helvetica, sans-serif; font-size: 14px; padding: 0px 0px 0px 10px; text-align: left;\"><a href=\"http://www.theherbsplace.com/onsale\" style=\"color: #5583c7;\" target=\"_blank\"><img alt=\"Nature's Sunshine\" src=\"http://image.exct.net/lib/ff2c1c757166/i/4/096bf034-0.jpg\" style=\"border: 0px; display: block;\" /></a></td><td align=\"right\" style=\"color: #6e6f74; font-family: Arial, Helvetica, sans-serif; font-size: 14px; padding: 0px;\" valign=\"middle\">\n"
" \n"
" \n"
" \n"
" \n"
" <table border=\"0\" cellpadding=\"0\" cellspacing=\"0\" style=\"border-spacing: 0px;\"><tbody>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")