const regex = new RegExp('(?<= \\;)( \\;| |\\n|\\r)+', '')
const str = `<tr><td align="left" style="color: #6e6f74; font-family: Arial, Helvetica, sans-serif; font-size: 14px; padding: 0px 0px 0px 10px; text-align: left;"><a href="http://www.theherbsplace.com/onsale" style="color: #5583c7;" target="_blank"><img alt="Nature's Sunshine" src="http://image.exct.net/lib/ff2c1c757166/i/4/096bf034-0.jpg" style="border: 0px; display: block;" /></a></td><td align="right" style="color: #6e6f74; font-family: Arial, Helvetica, sans-serif; font-size: 14px; padding: 0px;" valign="middle">
<table border="0" cellpadding="0" cellspacing="0" style="border-spacing: 0px;"><tbody>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}