import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<= \\;)( \\;| |\\n|\\r)+";
final String string = "<tr><td align=\"left\" style=\"color: #6e6f74; font-family: Arial, Helvetica, sans-serif; font-size: 14px; padding: 0px 0px 0px 10px; text-align: left;\"><a href=\"http://www.theherbsplace.com/onsale\" style=\"color: #5583c7;\" target=\"_blank\"><img alt=\"Nature's Sunshine\" src=\"http://image.exct.net/lib/ff2c1c757166/i/4/096bf034-0.jpg\" style=\"border: 0px; display: block;\" /></a></td><td align=\"right\" style=\"color: #6e6f74; font-family: Arial, Helvetica, sans-serif; font-size: 14px; padding: 0px;\" valign=\"middle\">\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " <table border=\"0\" cellpadding=\"0\" cellspacing=\"0\" style=\"border-spacing: 0px;\"><tbody>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}