use strict;
my $str = 'MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000123|||||||||||||||||||||||||||||||
ORC|NW||||||||20210710161803
OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F
OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL
MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||
ORC|CO||||||||20210710161803
OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F
OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL
MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000456|||||||||||||||||||||||||||||||
ORC|NW||||||||20210710161803
OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F
OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL
MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710165010||ORU^R01|SC20210710165010|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||
ORC|NW||||||||20210710165010
OBR|||SCVITALS-202107101650108370|SME^SunnyCare Manual Entry|||20210710110005|||anpatel~anpatel|||||||||||||||F
OBX|1|NM|0002-F828^SpRR||34|rpm|||||F|||20210710110005|||MANUAL
MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710165442||ORU^R01|SC20210710165442|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||
ORC|CO
OBR|||SCVITALS-202107101643353582|SME^SunnyCare Manual Entry|||20210710165442|||anpatel|||||||||||||||F
';
my $regex = qr/PV1\|(?:[^\|]*\|){18}1703000105\|(?:[^\|]*\|){31}CO/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}