# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"PV1\|(?:[^\|]*\|){18}1703000105\|(?:[^\|]*\|){31}CO"
test_str = ("MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3\n"
"PID|||7030389||Smith^John||20001010|M\n"
"PV1||I|||||||||||||||||1703000123|||||||||||||||||||||||||||||||\n"
"ORC|NW||||||||20210710161803\n"
"OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F\n"
"OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL\n"
"MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3\n"
"PID|||7030389||Smith^John||20001010|M\n"
"PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||\n"
"ORC|CO||||||||20210710161803\n"
"OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F\n"
"OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL\n"
"MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3\n"
"PID|||7030389||Smith^John||20001010|M\n"
"PV1||I|||||||||||||||||1703000456|||||||||||||||||||||||||||||||\n"
"ORC|NW||||||||20210710161803\n"
"OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F\n"
"OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL\n"
"MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710165010||ORU^R01|SC20210710165010|P|2.3\n"
"PID|||7030389||Smith^John||20001010|M\n"
"PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||\n"
"ORC|NW||||||||20210710165010\n"
"OBR|||SCVITALS-202107101650108370|SME^SunnyCare Manual Entry|||20210710110005|||anpatel~anpatel|||||||||||||||F\n"
"OBX|1|NM|0002-F828^SpRR||34|rpm|||||F|||20210710110005|||MANUAL\n"
"MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710165442||ORU^R01|SC20210710165442|P|2.3\n"
"PID|||7030389||Smith^John||20001010|M\n"
"PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||\n"
"ORC|CO\n"
"OBR|||SCVITALS-202107101643353582|SME^SunnyCare Manual Entry|||20210710165442|||anpatel|||||||||||||||F\n"
"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.