// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"PV1\|(?:[^\|]*\|){18}1703000105\|(?:[^\|]*\|){31}CO").unwrap();
let string = "MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000123|||||||||||||||||||||||||||||||
ORC|NW||||||||20210710161803
OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F
OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL
MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||
ORC|CO||||||||20210710161803
OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F
OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL
MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710161803||ORU^R01|SC20210710161803|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000456|||||||||||||||||||||||||||||||
ORC|NW||||||||20210710161803
OBR|||SCVITALS-202107101618037402|SME^SunnyCare Manual Entry|||20210710010005|||~|||||||||||||||F
OBX|1|NM|0002-F828^SpRR||24|rpm|||||F|||20210710010005|||MANUAL
MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710165010||ORU^R01|SC20210710165010|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||
ORC|NW||||||||20210710165010
OBR|||SCVITALS-202107101650108370|SME^SunnyCare Manual Entry|||20210710110005|||anpatel~anpatel|||||||||||||||F
OBX|1|NM|0002-F828^SpRR||34|rpm|||||F|||20210710110005|||MANUAL
MSH|^~\\&|SUNNY|SHSC|OACIS|SHSC|20210710165442||ORU^R01|SC20210710165442|P|2.3
PID|||7030389||Smith^John||20001010|M
PV1||I|||||||||||||||||1703000105|||||||||||||||||||||||||||||||
ORC|CO
OBR|||SCVITALS-202107101643353582|SME^SunnyCare Manual Entry|||20210710165442|||anpatel|||||||||||||||F
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}