const regex = /^.*\S\K\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\S\\K\\s+', 'g')
const str = `123123 123 A123`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);