# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\A((?:(?!127\.0\.0\.1\s)[\s\S])*?)(?:\Z|127\.0\.0\.1\s+(?!localhost)\S+\n|(127\.0\.1\.1\s+\S+(?![\s\S]*\n127\.0\.0\.1\s)\n))/\1\2127.0.0.1 localhost\n/;t' <<< "127.0.1.1 myhost
1.1.1.1 bla
127.0.0.1 bla
2.2.2.2 bla
"