use strict;
my $str = '127.0.1.1 myhost
1.1.1.1 bla
127.0.0.1 bla
2.2.2.2 bla
';
my $regex = qr/\A((?:(?!127\.0\.0\.1\s)[\s\S])*?)(?:\Z|127\.0\.0\.1\s+(?!localhost)\S+\n|(127\.0\.1\.1\s+\S+(?![\s\S]*\n127\.0\.0\.1\s)\n))/p;
my $subst = '\\1\\2127.0.0.1 localhost\\n';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";