#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\A((?:(?!127\.0\.0\.1\s)[\s\S])*?)(?:\Z|127\.0\.0\.1\s+(?!localhost)\S+\n|(127\.0\.1\.1\s+\S+(?![\s\S]*\n127\.0\.0\.1\s)\n))"
Local $sString = "127.0.1.1 myhost" & @CRLF & _
"1.1.1.1 bla" & @CRLF & _
"127.0.0.1 bla" & @CRLF & _
"2.2.2.2 bla" & @CRLF & _
""
Local $sSubst = "\1\2127.0.0.1 localhost\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)