#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?=(?>[^{}()<>]*\[+[^{}()<>]*\]+[^{}()<>]*)*$|(?>[^[\]()<>]*\{+[^[\]()<>]*\}+[^[\]()<>]*)*$|(?>[^[\]{}<>]*\(+[^[\]{}<>]*\)+[^[\]{}<>]*)*$|(?>[^[\]{}()]*\<+[^[\]{}()]*\>+[^[\]{}()]*)*$|(?>[^[\]{}()<>]*)*$)(?=(?>[^"]*\“+[^"]*\”+[^"]*)*$|(?>[^“”]*\"+[^“”]*\"+[^“”]*)*$|(?>[^"“”]*)*$)(?=(?>[^']*‘+[^']*’+[^']*)*$|(?>[^‘’]*'+[^‘’]*'+[^‘’]*)*$|(?>[^'‘’]*)*$)[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,-]{3}[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,\-*=#%+]{0,157}$"
Local $sString = "/^" & @CRLF & _
" (?=" & @CRLF & _
" (?> [^{}()<>]* \[+ [^{}()<>]* \]+ [^{}()<>]* ) *$|" & @CRLF & _
" (?> [^[\]()<>]* \{+ [^[\]()<>]* \}+ [^[\]()<>]* ) *$|" & @CRLF & _
" (?> [^[\]{}<>]* \(+ [^[\]{}<>]* \)+ [^[\]{}<>]* ) *$|" & @CRLF & _
" (?> [^[\]{}()]* \<+ [^[\]{}()]* \>+ [^[\]{}()]* ) *$|" & @CRLF & _
" (?> [^[\]{}()<>]* ) *$" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" (?=" & @CRLF & _
" (?> [^"]* \“+ [^"]* \”+ [^"]* ) *$|" & @CRLF & _
" (?> [^“”]* \"+ [^“”]* \"+ [^“”]* ) *$|" & @CRLF & _
" (?> [^"“”]* ) *$" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" (?=" & @CRLF & _
" (?> [^']* ‘+ [^']* ’+ [^']* ) *$|" & @CRLF & _
" (?> [^‘’]* '+ [^‘’]* '+ [^‘’]* ) *$|" & @CRLF & _
" (?> [^'‘’]* ) *$" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" [A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,-]{3}" & @CRLF & _
" [A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,\-*=#%+]{0,157}" & @CRLF & _
"$/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")