import re
regex = re.compile(r"^(?=(?>[^{}()<>]*\[+[^{}()<>]*\]+[^{}()<>]*)*$|(?>[^[\]()<>]*\{+[^[\]()<>]*\}+[^[\]()<>]*)*$|(?>[^[\]{}<>]*\(+[^[\]{}<>]*\)+[^[\]{}<>]*)*$|(?>[^[\]{}()]*\<+[^[\]{}()]*\>+[^[\]{}()]*)*$|(?>[^[\]{}()<>]*)*$)(?=(?>[^\"]*\“+[^\"]*\”+[^\"]*)*$|(?>[^“”]*\"+[^“”]*\"+[^“”]*)*$|(?>[^\"“”]*)*$)(?=(?>[^']*‘+[^']*’+[^']*)*$|(?>[^‘’]*'+[^‘’]*'+[^‘’]*)*$|(?>[^'‘’]*)*$)[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,-]{3}[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,\-*=#%+]{0,157}$")
test_str = ("/^\n"
" (?=\n"
" (?> [^{}()<>]* \\[+ [^{}()<>]* \\]+ [^{}()<>]* ) *$|\n"
" (?> [^[\\]()<>]* \\{+ [^[\\]()<>]* \\}+ [^[\\]()<>]* ) *$|\n"
" (?> [^[\\]{}<>]* \\(+ [^[\\]{}<>]* \\)+ [^[\\]{}<>]* ) *$|\n"
" (?> [^[\\]{}()]* \\<+ [^[\\]{}()]* \\>+ [^[\\]{}()]* ) *$|\n"
" (?> [^[\\]{}()<>]* ) *$\n"
" )\n\n"
" (?=\n"
" (?> [^\"]* \\“+ [^\"]* \\”+ [^\"]* ) *$|\n"
" (?> [^“”]* \\\"+ [^“”]* \\\"+ [^“”]* ) *$|\n"
" (?> [^\"“”]* ) *$\n"
" )\n\n"
" (?=\n"
" (?> [^']* ‘+ [^']* ’+ [^']* ) *$|\n"
" (?> [^‘’]* '+ [^‘’]* '+ [^‘’]* ) *$|\n"
" (?> [^'‘’]* ) *$\n"
" )\n\n"
" [A-Za-z0-9 \\\"“”'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,-]{3}\n"
" [A-Za-z0-9 \\\"“”'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,\\-*=#%+]{0,157}\n"
"$/")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")