$re = '/^(?=(?>[^{}()<>]*\[+[^{}()<>]*\]+[^{}()<>]*)*$|(?>[^[\]()<>]*\{+[^[\]()<>]*\}+[^[\]()<>]*)*$|(?>[^[\]{}<>]*\(+[^[\]{}<>]*\)+[^[\]{}<>]*)*$|(?>[^[\]{}()]*\<+[^[\]{}()]*\>+[^[\]{}()]*)*$|(?>[^[\]{}()<>]*)*$)(?=(?>[^"]*\“+[^"]*\”+[^"]*)*$|(?>[^“”]*\"+[^“”]*\"+[^“”]*)*$|(?>[^"“”]*)*$)(?=(?>[^\']*‘+[^\']*’+[^\']*)*$|(?>[^‘’]*\'+[^‘’]*\'+[^‘’]*)*$|(?>[^\'‘’]*)*$)[A-Za-z0-9 \"“”\'‘’()[\]{}<>«»\\\\\/?!&@£$€¥.,-]{3}[A-Za-z0-9 \"“”\'‘’()[\]{}<>«»\\\\\/?!&@£$€¥.,\-*=#%+]{0,157}$/';
$str = '/^
(?=
(?> [^{}()<>]* \\[+ [^{}()<>]* \\]+ [^{}()<>]* ) *$|
(?> [^[\\]()<>]* \\{+ [^[\\]()<>]* \\}+ [^[\\]()<>]* ) *$|
(?> [^[\\]{}<>]* \\(+ [^[\\]{}<>]* \\)+ [^[\\]{}<>]* ) *$|
(?> [^[\\]{}()]* \\<+ [^[\\]{}()]* \\>+ [^[\\]{}()]* ) *$|
(?> [^[\\]{}()<>]* ) *$
)
(?=
(?> [^"]* \\“+ [^"]* \\”+ [^"]* ) *$|
(?> [^“”]* \\"+ [^“”]* \\"+ [^“”]* ) *$|
(?> [^"“”]* ) *$
)
(?=
(?> [^\']* ‘+ [^\']* ’+ [^\']* ) *$|
(?> [^‘’]* \'+ [^‘’]* \'+ [^‘’]* ) *$|
(?> [^\'‘’]* ) *$
)
[A-Za-z0-9 \\"“”\'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,-]{3}
[A-Za-z0-9 \\"“”\'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,\\-*=#%+]{0,157}
$/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);