re = /^(?=(?>[^{}()<>]*\[+[^{}()<>]*\]+[^{}()<>]*)*$|(?>[^[\]()<>]*\{+[^[\]()<>]*\}+[^[\]()<>]*)*$|(?>[^[\]{}<>]*\(+[^[\]{}<>]*\)+[^[\]{}<>]*)*$|(?>[^[\]{}()]*\<+[^[\]{}()]*\>+[^[\]{}()]*)*$|(?>[^[\]{}()<>]*)*$)(?=(?>[^"]*\“+[^"]*\”+[^"]*)*$|(?>[^“”]*\"+[^“”]*\"+[^“”]*)*$|(?>[^"“”]*)*$)(?=(?>[^']*‘+[^']*’+[^']*)*$|(?>[^‘’]*'+[^‘’]*'+[^‘’]*)*$|(?>[^'‘’]*)*$)[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,-]{3}[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,\-*=#%+]{0,157}$/
str = '/^
(?=
(?> [^{}()<>]* \\[+ [^{}()<>]* \\]+ [^{}()<>]* ) *$|
(?> [^[\\]()<>]* \\{+ [^[\\]()<>]* \\}+ [^[\\]()<>]* ) *$|
(?> [^[\\]{}<>]* \\(+ [^[\\]{}<>]* \\)+ [^[\\]{}<>]* ) *$|
(?> [^[\\]{}()]* \\<+ [^[\\]{}()]* \\>+ [^[\\]{}()]* ) *$|
(?> [^[\\]{}()<>]* ) *$
)
(?=
(?> [^"]* \\“+ [^"]* \\”+ [^"]* ) *$|
(?> [^“”]* \\"+ [^“”]* \\"+ [^“”]* ) *$|
(?> [^"“”]* ) *$
)
(?=
(?> [^\']* ‘+ [^\']* ’+ [^\']* ) *$|
(?> [^‘’]* \'+ [^‘’]* \'+ [^‘’]* ) *$|
(?> [^\'‘’]* ) *$
)
[A-Za-z0-9 \\"“”\'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,-]{3}
[A-Za-z0-9 \\"“”\'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,\\-*=#%+]{0,157}
$/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end