using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9_#.-]+)@(([a-z0-9_#-]+\.)+[a-z]{2,})$";
string input = @"pippo.franco@gmail.edit.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}