package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-z0-9_#.-]+)@(([a-z0-9_#-]+\.)+[a-z]{2,})$`)
var str = `pippo.franco@gmail.edit.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}