$re = '/^([a-z0-9_#.-]+)@(([a-z0-9_#-]+\.)+[a-z]{2,})$/';
$str = 'pippo.franco@gmail.edit.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);