re = /^([a-z0-9_#.-]+)@(([a-z0-9_#-]+\.)+[a-z]{2,})$/
str = 'pippo.franco@gmail.edit.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end