#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<meta.*og:image.*?(http:\/\/.*?)"\s+\/>"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html>" & @CRLF & _
"<head>" & @CRLF & _
"<link href='http://fonts.googleapis.com/css?family=Raleway:400,700' rel='stylesheet' type='text/css'>" & @CRLF & _
"<link href='http://fonts.googleapis.com/css?family=Open+Sans+Condensed:700' rel='stylesheet' type='text/css'>" & @CRLF & _
"<link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet">" & @CRLF & _
"<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap.min.css">" & @CRLF & _
"<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap-theme.min.css">" & @CRLF & _
"<link rel="stylesheet" type="text/css" href="http://www.text.ru/css/style.css?v=58539">" & @CRLF & _
"<link rel="stylesheet" type="text/css" href="http://www.text.ru/css/responsive.css?v=28967">" & @CRLF & _
"<title>Afla ce iti doreste AppLine !</title>" & @CRLF & _
"<meta http-equiv="X-UA-Compatible" content="IE=edge">" & @CRLF & _
"<meta content="width=device-width, initial-scale=1" name="viewport">" & @CRLF & _
"<meta property="og:title" content="text!"/>" & @CRLF & _
"<meta property="og:type" content="website"/>" & @CRLF & _
"<meta property="og:description" content="text !"/>" & @CRLF & _
"<meta property="og:image" content="http://www.example.ro/images/ex/0166627d.png" /> " & @CRLF & _
"HERE;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")