import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<meta.*og:image.*?(http:\\/\\/.*?)\"\\s+\\/>";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ "<head>\n"
+ "<link href='http://fonts.googleapis.com/css?family=Raleway:400,700' rel='stylesheet' type='text/css'>\n"
+ "<link href='http://fonts.googleapis.com/css?family=Open+Sans+Condensed:700' rel='stylesheet' type='text/css'>\n"
+ "<link href=\"https://maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css\" rel=\"stylesheet\">\n"
+ "<link rel=\"stylesheet\" href=\"https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap.min.css\">\n"
+ "<link rel=\"stylesheet\" href=\"https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap-theme.min.css\">\n"
+ "<link rel=\"stylesheet\" type=\"text/css\" href=\"http://www.text.ru/css/style.css?v=58539\">\n"
+ "<link rel=\"stylesheet\" type=\"text/css\" href=\"http://www.text.ru/css/responsive.css?v=28967\">\n"
+ "<title>Afla ce iti doreste AppLine !</title>\n"
+ "<meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge\">\n"
+ "<meta content=\"width=device-width, initial-scale=1\" name=\"viewport\">\n"
+ "<meta property=\"og:title\" content=\"text!\"/>\n"
+ "<meta property=\"og:type\" content=\"website\"/>\n"
+ "<meta property=\"og:description\" content=\"text !\"/>\n"
+ "<meta property=\"og:image\" content=\"http://www.example.ro/images/ex/0166627d.png\" /> \n"
+ "HERE;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}