import re
regex = re.compile(r"<meta.*og:image.*?(http:\/\/.*?)\"\s+\/>")
test_str = ("<!DOCTYPE html>\n"
"<html>\n"
"<head>\n"
"<link href='http://fonts.googleapis.com/css?family=Raleway:400,700' rel='stylesheet' type='text/css'>\n"
"<link href='http://fonts.googleapis.com/css?family=Open+Sans+Condensed:700' rel='stylesheet' type='text/css'>\n"
"<link href=\"https://maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css\" rel=\"stylesheet\">\n"
"<link rel=\"stylesheet\" href=\"https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap.min.css\">\n"
"<link rel=\"stylesheet\" href=\"https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap-theme.min.css\">\n"
"<link rel=\"stylesheet\" type=\"text/css\" href=\"http://www.text.ru/css/style.css?v=58539\">\n"
"<link rel=\"stylesheet\" type=\"text/css\" href=\"http://www.text.ru/css/responsive.css?v=28967\">\n"
"<title>Afla ce iti doreste AppLine !</title>\n"
"<meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge\">\n"
"<meta content=\"width=device-width, initial-scale=1\" name=\"viewport\">\n"
"<meta property=\"og:title\" content=\"text!\"/>\n"
"<meta property=\"og:type\" content=\"website\"/>\n"
"<meta property=\"og:description\" content=\"text !\"/>\n"
"<meta property=\"og:image\" content=\"http://www.example.ro/images/ex/0166627d.png\" /> \n"
"HERE;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")