#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z-]*[a-zA-Z]+\.){1,}[a-zA-Z-]*[a-zA-Z]+$"
Local $sString = "abc123" & @CRLF & _
"1edc2" & @CRLF & _
"-blub" & @CRLF & _
"notthisone-" & @CRLF & _
"ornament" & @CRLF & _
"---a" & @CRLF & _
"abc123.def" & @CRLF & _
"---a.-----b" & @CRLF & _
"not.-this-" & @CRLF & _
"-inc-clude-a.this" & @CRLF & _
"-ex-clude-.this" & @CRLF & _
"github-bg.com.uk.bg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")