re = /([a-zA-Z-]*[a-zA-Z]+\.){1,}[a-zA-Z-]*[a-zA-Z]+$/m
str = 'abc123
1edc2
-blub
notthisone-
ornament
---a
abc123.def
---a.-----b
not.-this-
-inc-clude-a.this
-ex-clude-.this
github-bg.com.uk.bg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end