using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z-]*[a-zA-Z]+\.){1,}[a-zA-Z-]*[a-zA-Z]+$";
string input = @"abc123
1edc2
-blub
notthisone-
ornament
---a
abc123.def
---a.-----b
not.-this-
-inc-clude-a.this
-ex-clude-.this
github-bg.com.uk.bg
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}