package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z-]*[a-zA-Z]+\.){1,}[a-zA-Z-]*[a-zA-Z]+$`)
var str = `abc123
1edc2
-blub
notthisone-
ornament
---a
abc123.def
---a.-----b
not.-this-
-inc-clude-a.this
-ex-clude-.this
github-bg.com.uk.bg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}