#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(11)(?:,))|((?<=,)(11)(?:,))|(,11$)"
Local $sString = "11,11,22,33,56711,4114,55,6611" & @CRLF & _
"11,45611,22,11,33,44" & @CRLF & _
"22,1133,611,44,55,66,11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")