use strict;
my $str = '11,11,22,33,56711,4114,55,6611
11,45611,22,11,33,44
22,1133,611,44,55,66,11';
my $regex = qr/(^(11)(?:,))|((?<=,)(11)(?:,))|(,11$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}