$re = '/(^(11)(?:,))|((?<=,)(11)(?:,))|(,11$)/m';
$str = '11,11,22,33,56711,4114,55,6611
11,45611,22,11,33,44
22,1133,611,44,55,66,11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);