using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(11)(?:,))|((?<=,)(11)(?:,))|(,11$)";
string input = @"11,11,22,33,56711,4114,55,6611
11,45611,22,11,33,44
22,1133,611,44,55,66,11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}