#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#\s*Person(\n|.)+(?=#\s*Pet)"
Local $sString = "# Person" & @CRLF & _
"---" & @CRLF & _
"Name: Nick King " & @CRLF & _
"Age: 18" & @CRLF & _
"Speech: "Hello!! How are you? Me & you are different. I'm the #1"" & @CRLF & _
"" & @CRLF & _
"# Pet = Dog" & @CRLF & _
"---" & @CRLF & _
"Name: Bill" & @CRLF & _
"" & @CRLF & _
"# Pet = Cat" & @CRLF & _
"---" & @CRLF & _
"Name: Zacky" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")