const regex = /#\s*Person(\n|.)+(?=#\s*Pet)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#\\s*Person(\\n|.)+(?=#\\s*Pet)', 'gm')
const str = `# Person
---
Name: Nick King
Age: 18
Speech: "Hello!! How are you? Me & you are different. I'm the #1"
# Pet = Dog
---
Name: Bill
# Pet = Cat
---
Name: Zacky
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}