use strict;
my $str = '# Person
---
Name: Nick King
Age: 18
Speech: "Hello!! How are you? Me & you are different. I\'m the #1"
# Pet = Dog
---
Name: Bill
# Pet = Cat
---
Name: Zacky
';
my $regex = qr/#\s*Person(\n|.)+(?=#\s*Pet)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}