using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#\s*Person(\n|.)+?(?=#\s*Pet)";
string input = @"# Person
---
Name: Nick King
Age: 18
Speech: ""Hello!! How are you? Me & you are different. I'm the #1""
# Pet = Dog
---
Name: Bill
# Pet = Cat
---
Name: Zacky
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}