import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#\\s*Person(\\n|.)+?(?=#\\s*Pet)";
final String string = "# Person\n"
+ "---\n"
+ "Name: Nick King \n"
+ "Age: 18\n"
+ "Speech: \"Hello!! How are you? Me & you are different. I'm the #1\"\n\n"
+ "# Pet = Dog\n"
+ "---\n"
+ "Name: Bill\n\n"
+ "# Pet = Cat\n"
+ "---\n"
+ "Name: Zacky\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}