import Foundation
let pattern = ##"#\s*Person(\n|.)+?(?=#\s*Pet)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Person
---
Name: Nick King
Age: 18
Speech: "Hello!! How are you? Me & you are different. I'm the #1"
# Pet = Dog
---
Name: Bill
# Pet = Cat
---
Name: Zacky
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)